哪个大佬能帮我看下C语言的这道题吗

哪个大佬能帮我看下C语言的这道题吗Problem Statement
A programming competition site AtCode regularly holds programming contests.
The next contest on AtCode is called ABC, which is rated for contestants with ratings less than 1200.
The contest after the ABC is called ARC, which is rated for contestants with ratings less than 2800.
The contest after the ARC is called AGC, which is rated for all contestants.
Takahashi's rating on AtCode is R. What is the next contest rated for him?

Constraints
0≤R≤4208R is an integer.
Input
Input is given from Standard Input in the following format:
R

Output
Print the name of the next contest rated for Takahashi (ABC, ARC or AGC).

Sample Input 1
1199

Sample Output 1
ABC

1199 is less than 1200, so ABC will be rated.

Sample Input 2
1200

Sample Output 2
ARC

1200 is not less than 1200 and ABC will be unrated, but it is less than 2800 and ARC will be rated.

Sample Input 3
4208

Sample Output 3
AGC

Submit

#include <stdio.h>

int main()
{
    int rate;
    
    while( scanf("%d", &rate) != EOF )
    {
        if( rate < 1200 ){
            puts("ABC");
        }else if( rate < 2800 ){
            puts("ARC");
        }else{
            puts("AGC");
        }
    }
    
    return 0;
}

温馨提示:答案为网友推荐,仅供参考
相似回答